Skyrim Dragonslayer quest bug?

Discuss all things PlayStation 3 which are not covered by the other sections. Just keep the conversations abiding by the forum rules.

Moderators: PikaFiend, Kitsune, Gaarasaiyan

Skyrim Dragonslayer quest bug?

Postby alanwaston » Tue Dec 20, 2016 9:50 pm

Well ive been at this quest a long long time, thinking im missing something finally decided to google it and ive done everything right as far as i can see but no Alduin.

So i tried to exit and enter again, still no alduin.

Tried to load old save and still no alduin.

So either this is a killer bug or im missing something.

WIth the heroes, used clearsky 30/40 times this try at least there is no fog around me, the fog doesnt come back, there is fog everywhere else that doesnt dispel but not on the feild.

The heroes used to help with the shout but they havent in a very long time.

any help appreciated, giving up for the night but ill pick it up when i get home tomorrow.
New Member
Posts: 5
Joined: Tue Nov 08, 2016 3:07 am

Return to PlayStation 3 chat

Who is online

Users browsing this forum: No registered users and 2 guests